PDA

View Full Version : Updating to v.1.3



Dvoid
03-06-2007, 11:10 AM
I just finished on Normal and am continuing at Epic level. Can I upgrade to the patch at this time and continue my character or do I have to start a new character after installing the patch?

Shadow_azzazen
03-06-2007, 11:22 AM
You character can proseed as normal, all though it will change a bit, see change logg for more information;)

Infares
03-07-2007, 01:45 PM
I'd suggest updating your Titan Quest to 1.30 before you install the xpack.

Stonga
03-07-2007, 09:56 PM
I'd suggest updating your Titan Quest to 1.30 before you install the xpack.

Why?

The original game will be updated when you start up the expansion.

- Stonga.

Infares
03-07-2007, 10:03 PM
The original game will be updated when you start up the expansion.

Take what I'm about to say with a big grain of salt.

There appears to be a pattern forming of people that prepatched to 1.30 in Titan Quest before installing Immortal Throne having fewer bugs surface (like quest logs missing, display bugs, characters not porting over properly) than those that didn't.

Maybe it's just me.

Minervian
03-07-2007, 10:42 PM
There appears to be a pattern forming of people that prepatched to 1.30 in Titan Quest before installing Immortal Throne having fewer bugs surface (like quest logs missing, display bugs, characters not porting over properly) than those that didn't.


Is that so really? I was just about to ask you guys if I should patch now (IT still 2 weeks away where I live). Hmmm... decisions decisions! :D ;)

Stonga
03-08-2007, 07:12 AM
One question. Playing IT v1.1 is just the same as playing TQ 1.30?
The same patch notes apply to IT 1.1 too?

I'm asking cause i started my Slayer in IT 1.1 and he's level 31 now.

- Stonga.

The Rock-man
03-08-2007, 09:24 AM
1.30 aplies to normal TQ acts 1-3 and 1.1 TQ:IT is for act 4. As i understand it

Infares
03-08-2007, 01:11 PM
1.30 aplies to normal TQ acts 1-3 and 1.1 TQ:IT is for act 4. As i understand it

It's supposed to be the same rules and same patch but it's not, some people are reporting some bugs not present in TQIT v1.1 are still there in TQ v1.30, like Resilience Exploit and whatnot.

The Rock-man
03-10-2007, 05:59 AM
I ment that 1.30 is for stuff the purely act 1-3 and it 1.1 for act 4 + new stuff, skills come under IT 1.1 due to dream mastery.